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PART-I
Choose the most appropriate answer : 

[75 × 1 = 75]

1. What value is stored in the variable c, if  
a = 5; c = a++;
a) 5 b) 6 c) 0 d) 10

2.	 In	Star	Office	Base	which	option	is	used	to	
specify	if	the	user	should	always	enter	a	value	
for	that	field?
a)	 Entry	Required	 	
b) Default value
c) Length
d) Format

3.	 	Which	coloured	squiggly	underline	is	used	for	
the words that do not match with the words in 
the	dictionary	in	StarOffice	Writer?
a)	 Blue	
b) Green 
c)	 Red	
d) White

4. Which of the following command is used to 
print	the	presentation?
a) File → Print
b) Edit → Print
c) Tools→ Print
d) Format → Print

5.	 Which	of	the	following	act	as	place	holders	
in	the	function	prototype	in	C++?
a) variables 
b)	 typedef
c) character 
d) enumerator

6.	 In	StarOffice	Calc,	in	Page	style	Dialog	Box	
which	Check	Box	should	be	clicked	to	print	
a	worksheet	with	gridlines?	
a) Sheet
b) Page
c) Grid 
d) Format

7.	 The	default	 top	 and	bottom	margins	 are	 in	
how	many	inches	in	StarOffice	Writer.
a) 1.25 
b) 0.5
c) 1
d) 1.5

8. Which	key	is	used	to	end	the	presentation?
a) Ctrl 
b) Alt
c) Delete
d) Esc

9. Which is the illegal access to the network or 
computer	system?

a) Ethics 
b) Virus
c) Software
d) Cracking

10.	Which	command	is	used	to	hide	a	slide?
a) Tools → Show/Hide Show 
b) Tools → Hide Show 
c) Format → Hide Slide  
d) Slide Show → Show/Hide Slide

(1)



SURA B
OOKS

2 Sura’s  XII Std  Computer Science  2016 – October Question Paper with Answers

11.	Expansion	of	GIF:

a)	 Graphic	Information	Format
b)	 Graphic	Interchange	Format
c)	 Graphic	Interchange	File
d)	 Graphic	Information	File

12.	In	C++	the	body	of	the	class	is	terminated	by:	

a) : b) :: c) () d) ;
13.	Which	of	the	following	displays	the	fields	of	

a	record	in	a	well	-	spaced	out	manner?

a) Table b) Form
c)	 Report	 d)	 Query

14.	Which	 of	 the	 following	 function	 copies	
Source	String	to	Target	String?

a)	 Stringcopy	()
b)	 Strcpy()
c)	 Strcmp()
d)	 Strcpy()

15.	Which	one	of	the	following	is	called	the	entry-
check	loop	in	C++	?
a) do..while  b) while
c) continue  d) break

16.	Which	one	of	 the	 following	 is	 the	multiple	
branching	statement	in	C++?
a) Switch   b) if
c) while    d) do..while

17. In C++, which one of the following braces is 
used	to	enclose	the	body	of	a	class	?

a) () b) {} c) [] d) < > 

18.	Which	 of	 the	 following	 is	 executed	 in	 the	
order	of	inherited	class?

a)	 Polymorphism

b) Destructor

c) Constructor

d) Function

19.	Making	 and	 using	 duplicate	 hardware	 and	
software is called :

a) Virus

b) Ethics

c)	 Piracy

d) Cracking
20.	Which	 is	 a	 telephone	based	 shared	 service	

center	for	a	specific	customer	activities?
a) Data Management 
b) Call Center
c) Digitization
d)	 Morphing

21.	Which	one	of	the	following	process	to	join	
the data from more than different tables in 
a	Database?

a) Sorting b) Filter

c) Searching d) Merging

22.	Which	of	 the	 following	 is	 the	 extension	of	
shockwave	format?

a) .snd b) .swf

c) .snf d) .swd
23. Which of the following sign is used to make 

the	cell	address	absolute	in	StarOffice	Calc?	

a) # b) &

c) $ d) %

24.	Which	one	of	the	following	in	C++	is	memory	
box	that	hold	values	or	constants?

a)	 punctuators	

b)	 keywords

c) constants 

d) variables
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25.	In	 C++	 the	mechanism	 of	 giving	 special	
meaning	to	an	operator	is	called	:

a) Function Overloading 

b)	 Operator	Overloading

c) Constructor Overloading 

d) Destructor Overloading
26.	Which	of	 the	following	is	used	to	uniquely	

identify	a	record	in	a	database	table?

a)	 Field	 	 	 b)	 Record

c)	 File	 	 	 d)	 Primary	Key
27.	In	C++	which	statement	would	exit	the	current	

loop	only	?

a) for 

b) switch

c) struct

d) break

28.	Which	of	the	following	is	the	most	powerful	
feature	of	an	Objected	Oriented	Programming	
language	?
a) Class   b) Abstract
c) Constructor d) Inheritance

29. Which of the following is a named set of 
defaults	for	formatting	text	?

a)	 Style	 b)	 Formatting

c)	 Font	type	 d)	 Points
30.	How	many	copy	of	 the	member	variable	 is	

created	for	static	data	members	in	C++	?

a) One

b) Two

c) Three 

d) Four

31.Which command is used to change the column 
width	of	a	Worksheet	in	StarOffice	Calc	?

a) Format → Width → Column 

b) Format → Column → Height 

c) Format → Height → Column  

d) Format → column → width
32. In C++ a collection of variables of the same 

type	is	:

a) Function 

b)	 Operators

c) Pointer 

d)	 Array
33.	When	a	derived	class	inherits	only	from	one	

base class it is known as :

a) Single Inheritance

b)	 Multiple	Inheritance

c) Multilevel Inheritance

d)	 Hybrid	Inheritance
34.	How	many	kinds	of	loops	are	there	in	C++	?

a) four b) three
c)	 two	 d)	 five

35. In StarOffice Calc which of the following 
bar	 is	used	 to	display	 the	current	cell	and	 its	 
contents	?
a)	 Function	 b)	 Object
c) Formula d) Status

36. How	many	field	types	are	there	in	StarOffice	
Base	?
a) 10 b) 20 c) 30 d) 40

37. In StarOffice	Writer	which	button	is	used	to	
add	the	word	to	the	dictionary?
a)	 Add	 b)	 Replace
c) Insert d) Suggestions
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38.	Expansion	of	DBMS	:
a)	 Data	Base	Management	System
b)	 Data	Base	Memory	System
c)	 Data	Base	Memory	Storage
d)	 Device	Based	Memory	Storage

39. Which one of the following reduces software 
complexity	?
a)	 Polymorphism
b) Inheritance
c)	 Object
d) Class

40.	In	StarOffice	Writer	which	command	is	used	
to	insert	more	than	one	row	in	the	table	?

a) Table → Insert → Rows 

b) Format → Insert → Rows 

c) Tools → Insert → Rows 

d) File → Rows	→ Insert 
41.	In	C++	which	of	 the	 following	 is	a	 special	

function	that	cannot	be	overloaded?

a) Constructor
b) Destructor
c)	 Operator
d) Function

42. In C++ which one of the following is used as 
prefix	to	destructor	?

a) ~ b) @ c) ! d) #

43.	In	C++	which	of	the	following	operator		when	
overloaded through a member function take 
one	explict	argument	?

a)	 Unary

b)	 Ternary

c)	 Binary

d) Function

44.	In	StarOffice	Writer,	the	flashing	vertical	bar	
is called :

a) Pointer

b)	 Operators

c) Insertion Point

d)	 Key
45. Which one of the following is used to 

construct	C++	basic	statements	?

	 a)	 Symbols

	 b)	 Operators	

 c) Tokens

 d) Functions
46. The functions that return no value in C++ is 

declared as :

a) main 

b) cout

c) cin

d) void
47.	In	StarOffice	Writer	which	command	is	used		

to	insert	page	numbers	in	each	page	?

a) Format → Fields → Page Number

b) View → Fields → Page Number

c) Tools → Insert → Page Number

d) Insert → Fields → Page Number
48.	In	which	year,	Real	Audio	/	Real	Video	format	

was	developed	?

a) 1981 b) 1995 c) 1982 d) 1994
49.	Integral	data	promotion	in	C++	is	purely	what	

oriented	?	
a)	 Object	 	 	 b)	 Computer
c)	 Calculator		 d)	 Compiler
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50.	Reducing	 the	frame	count	 to	 less	 than	how	
many	frames	per	second	causes	the	video	to	
look	jerky	?

a) 40 b) 15
c) 20 d) 25

51. In C++ Member functions are called :

a)	 Access	specifier	 b)	 Attributes
c)	 Methods	 d)	 Operator

52.	The	name	C++	was	coined	by	:

a)	 Dennis	Ritchie	
b)	 Dan	Bricklin
c)	 Rick	Mascitti
d)		 Bjarne	Stroustrup

53.	Whic	key	 is	used	 to	make	 the	selected	 text	
bold	in	StarOffice	Writer	?

a)	 Ctrl	+	A	 b)	 Ctrl	+	B
c) Ctrl + C d) Ctrl + D

54.	In	StarOffice	Impress	which	of	the	following	
command	 is	 used	 to	 open	Media	 Player	
Window	?

a) View → Media	Player	
b) Format → Media	Player	
c) Tools → Media	Player	
d) Insert → Media	Player	

55.	In	C++	which	 function	 execute	 faster	 but	
require	more	memory	space	?

a) cinline
b) inline
c) outline
d) coutline

56.	Which	function	is	used	to	find	square	root	of	
a	given	number	in	StarOffice	Calc	?

a)	 SQUARE()	 b)	 ROOT()
c)	 SQRT()	 	 d)	 SQR()

57. In C++, which one of the folowing is called 
scope	resolution	operator	?

a)	 ::	 b)	 &?
c)	 ?:	 d)	 &

58.	Which	key	is	used	to	move	the	insertion	point	
to	 the	 beginning	 of	 the	 line	 in	 StarOffice	
Writer	document	?

a) Alt + Home b) Shift + Home
c) Ctrl + Home d) Home

59.	Which	of	 the	 following	operator	 is	used	 to	
combine	sections	of	text	in	StarOffice	Calc	?
a) : b) & c) ! d) $

60. Which view allows to view miniature images 
of	all	the	slides	in	the	presentation	?

a) Slide Sorter b) Normal
c) Notes d) Outline

61.	The	number	of	an	element	in	the	array	
 int a [2] [4];

a) 4 b) 6 c) 8 d) 12
62. The	First	Electronic	Spread	Sheet	:

a) Lotus 1 - 2 - 3 b) VisiCalc
c)	 Excel	 d)	 Improve

63. Which of the following database consists of 
single	data	table	?

a)	 Relational		 b)	 Flat	-	File
c)	 Object	Oriented	 d)	 Hierarchical

64.	How	many	storage	specifiers	are	there	in	C++?	

a) One b ) Two c) Three d) Four
65.	A	category	of	IT	enabled	services	pertaining	to	

collection,	digitization	and	processing	of	data	
coming from various source is :

 a) Tele - Medicine 
b) Website Service 
c) e - Governance 
d) Data Management
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66. Information is :
a) Set of Processed Constant 
b) Set of Processed Data
c)	 Set	of	processed	Command	
d)	 Set	of	Processed	Operator

67.	In	C++	which	of	the	following	operator	is	used	
to	access	the	members	of	a	class	?
a) dot (.)   b) Semicolon (;)
c) Comma(,)  d) Colon (:)

68.	In	C++	which	access	specifier	is	used	to	access	
the	members	only	from	within	the	class	?
a) Private b) Protected
c) Public d) Static

69.	Which	is	the	technique	of	distorting	a	single	
image	to	represent	something	else	?
a)	 Morphing	 b)	 Animating
c)	 Modeling	 d)	 Warping

70.	Which	of	the	following	function	gets	executed	
when	an	instance	of	a	class	comes	into	scope?

a) Method b) Arguments
c) Destructor d) Constructor

71.	In	C++	which	function	removes	the	memory	
of	 an	 object	 which	was	 allocated	 by	 the	
constructor	?

 a) Pointer b) Destructor
	 c)	 Copy	Constructor	 d)	 Modifier
72.	Expansion	of	CBT	:

a)	 Common	Business	Tool
b)	 Calculator	Based	Tools
c)	 Computer	Based	Tutorials
d)	 Computer	Based	Tools

73.	In	 StarOffice	 Base,	 each	 row	 in	 a	 table	
represents	:

a) File b) Field
c)	 Record	 d)	 Data

74.	Which	permits	banking	from	the	comfort	of	
the	home	by	using	Internet	facilities	?	

a)	 e	-	Learning	 b)	 e	-	Shopping
c)	 e	-	Banking	 d)	 e	-	Governance

75. Which one of the following increases the 
functionality	 of	 a	 derived	 class	 and	promo	
reusability	of	the	base	class	?

a)	 Encapsulation
b) Inheritance
c)	 Polymorphism
d)	 Object

PART-II

Answer any twenty 	questions	in	one or two 
sentences each :  [20 × 2 = 40]

76.	What	is	text	editing?

77.	What	is	meant	by	autospell	check	icon	?

78.	Can	we	change	the	data	present	in	a	cell	?	If	
so,	how	?

79.	List	the	type	of	cell	referencing	in	StarOffice	
Calc.

80.	What	is	Primary	Key	?	Give	example.

81.	What	is	form	?

82. What is Compression	?	Explain	the	types.

83. Write short note on MIDI format.

84. How to  inser t  and  de le te  s l ide  in  
Presentation	?

85. How to start  custom sl ide show in  
Presentation	?

86.	Define	Object	?
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87.	Write	note	on	conditional	operator	in	C++.

88.	Write	about	typedef	wth	example.

89.	Write	down	the	impact	of	modifiers	in	C++	?

90. Write note on nested if statement.

91.	What	are	 the	types	of	scope	of	variables	 in	
C++	?

92.	Write	short	note	on	strlen()	with	example.

93.	What	is	Matrix	?

94.	Define	Class.

95. Write note on 
 (1) Data Members
 (2) Member functions.

96.	What	is	meant	by	operator	overloading	?.

97.	What	are	the	functions	of	constructor	?

98.	List	the	types	of	inheritance.

99. Write note on e - Governance.

100.	What	is	Virus	?

PART-III

Answer any seven questions.  [7 × 5 = 35]

101.	Write	 the	 steps	 involved	 in	 search	 and	
replacing	a	given	text	in	StarOffice	Writer.

102.	In	 StarOffice	Writer	what	 are	 the	 various	
functions of the icons in the table formatting 
toolbar	?

103.	Explain	how	to	insert	objects	in	StarOffice	
Calc. 

104. List the advantages of using electronic 
spreadsheet.

105.	Explain	the	types	of	databases.

106.	Explain	loops	with	suitable	example	in	C++.

107.	Explain	 inline	 function	 with	 suitable	
example.

108.	Define	function	overloading.	List	the	rules	
of function overloading.

109.	Debug	the	following	C++	program	to	get	the	
following	output	:

output
 3
 4
 5
Program :
# include (iostream. h)
# include < conio.h >
class A
{
	 public;
 int a1,a2:a3;
 Void getdata[]
 {
   a1=3;
   a2=3;a3=5;
  }
}
Class	B::	public	A()
{
	 PUBLIC
 void func()
 {
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  int b1:b2:b3;
  A::getdata[];
  b1=a1;
  b2=a2;
  a3=a3;
  cout<<b1<<'\t'<<b2<<'\t'<<b3;
 }
void main()
{
 clrscr();
	 B	der;
 der1:func();
 getch();
}

110.	Find	 the	 output	 for	 the	 following	 C++	
program.
#include<iostream. h>
#include<conio.h>
class	sample

{

	 private:

 int a, b;

	 public:

	 	 sample()

  {

   a=b=0;

   cout<<"\nConstructor of class  
	 	 	 	 	 	 sample";

  }

	 	 	 ~sample()

	 	 	 cout<<"\nDestructor	of	class	sample";

  }

  void assign()

  {

   a=25;

   b=85;

  }

	 	 void	display()

  {

   cout<<"\nThe two integers are"

     <<a<<'\t'<<b;

   cout<<"\nThe sum of integers"<<a+b;

  }

 };

void main()

{

	 sample	obj;

	 cout<<"\n	Object";

	 obj.assign();

	 obj.display();

}  

]]]]
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Answers
PART - I

 1. (a); 2. (a); 3. (c); 4. (a); 5. (a); 6. (b); 7. (c); 8. (d); 9. (b); 10.   (d); 

 11. (b); 12. (d); 13. (b); 14. (b); 15. (a); 16. (a); 17 . (b); 18. (c); 19. (c); 20.   (b); 

 21. (d); 22. (b); 23. (c); 24. (d); 25. (b); 26. (d); 27. (d); 28. (d); 29. (a); 30.   (a); 

 31. (d); 32. (d); 33. (a); 34. (b); 35. (c); 36. (b); 37. (a); 38. (a); 39. (a); 40.   (a); 

 41. (b); 42. (a); 43. (c); 44. (c); 45. (c); 46. (d); 47. (d); 48. (b); 49. (d); 50.   (b); 

 51. (c); 52. (d); 53. (b); 54. (c); 55. (b); 56. (c); 57. (a); 58. (c); 59. (c); 60.   (a); 

 61. (c); 62. (b); 63. (b); 64. (d); 65. (d); 66. (b); 67. (a); 68. (b); 69. (d); 70.   (d); 

 71. (b); 72. (c); 73. (c); 74. (c); 75. (b).

PART -II

76. Entering	 a	 new	 text	 or	 modifying	 the	
existing	text	in	a	document	is	known	as	text	
editing. 

77. StarOffice	Writer	will	automatically	correct	
some	 spelling	mistakes.	 StarOffice	Writer	
recognises	 some	 common	misspellings	
and	 typographical	 mistakes	 and	 makes	
the	 replacement	 	 automatically	 using	 auto	
correction	option.	

 E.g:	 If	a	word	 is	 typed	as	 ‘teh’	StarOffice	
Writer	automatically	 replaces	 this	with	 the	
correct word ‘the’. 

78.	 To	edit	the	contents	in	a	cell	the	ways	are	:
	 (i)	 	Type	 in	 the	 new	data.	The	new	data	

will	simply	overwrite	the	old	contents	
of the cell. 

 (ii)  Click on the formula bar with the 
mouse,	 press	 the	F2	 function	key	or	
simply	 double-click	 on	 the	 cell.	A	
vertical	cursor	appears	on	the	formula	
bar. Move the cursor to the left using 

the	left	arrow	key	or	the	backspace	key	
and edit the data. 

79. The	two	types	of	cell	referencing	are	:

(i)	 Relative	cell	addressing,	

(ii) Absolute cell addressing. 
80.	 A	 primary	 key	 is	 a	 key	 that	 uniquely	

identifies	 a	 record	 in	 a	 database	 table.	 In	
relational	 database,	 a	 primary	 key	 can	
consist	of	one	or	more	fields.	

 Example : In a mark list table ‘regno’ is 
primary	 key	 since	 it	 uniquely	 identifies	 a	
student record. 

81.	 A	 form	 is	 simply	 a	 screen	 that	 displays	
the	 fields	 of	 a	 record	 in	well-spaced	 out																							
manner. 

	 Forms	are	user	defined	screens	that	are	used	
to make it easier to enter, view and edit the 
data	in	a	table	or	a	query.	

82.	 Compression	 is	 a	 technique	 by	which	 a	
recurring	set	of	information	is	identified	and	
replaced	by	a	single	piece	of	information.
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 The	two	types	of	video	compressions	are	:	
 (i)  Lossless compression: Retains	

the	 exact	 image	 throughout	 the	
compression.	

 (ii)  Lossy compression: Provides a 
comparat ively 	 higher 	 ra t io 	 of	
compression	but	 results	 in	some	 loss	
of	quality.

83. The Musical Instrument Digital Interface or 
the	MIDI	format	is	one	that	is	commonly	used	
for transferring music information between 
electronic	music	 devices	 like	 synthesizers	
and	sound	card	in	computers.

84. To insert a slide, click the Slide button in the 
Presentation toolbar or choose Insert → Slide 
from the menu bar. The new slides uses the 
page	layout	of	the	previous	slide.	

 To delete a slide, select the slide, to delete in 
the	Slides	Pane	and	press	Delete	key	or	right	
click on the slide, and choose Delete Slide. 

85. To start a custom slide show : 
 (i)  Choose Slide Show → Custom Slide 

Show. 
 (ii)  Select the slide show the user want to 

start from the list. 
 (iii) Click Start.  
86. An	object	is	a	group	of	related	functions	and	

data.	An	object	 is	 a	 kind	of	 self-sufficient	
‘sub-program’	with	a	specific	functional	area.

87. Conditional	Operator?:	 (num	1	>	num	2)?	
“true”	 :	 “else”	 -?:	 Is	 a	 ternary	 operator. 
 num1 > num2,” “true”, “false”, are 
theoperands.	A	ternary	operator	(?:)	is	also	
called	as	conditional	operator.	The	general	
syntax	is	E1?	E2:	E3	where	E1,	E2	and	E3	
are	 values	 or	 statements.	 (for	 example	 to	
assign	the	maximum	value	of	the	two	values	
one	can	express	it	as:	max=(num1	>	num2)?	
num1	>	num2;	The	variable	max	will	 take	
the value of num 1 if num 1 is greater than 
num	2,	otherwise	max	will	be	assigned	with	
the value of  num 2.

88. Users can define a variable that would 
represent	 an	 existing	 data	 type.	 “Type	
definition”	 allow	users	 to	 define	 such	user	
defined	data	type	identifier.	

 The syntax :

	 typedef	data_type	user_defined_data_type_
identifier;

 For example:

	 	 typedef	int	marks;

	 	 typedef	char	grade;

89.	 The	impact	of	modifiers. 

 (i)  unsigned modifies the range of the 
integer values as the sign bit is also used 
to store data. 

 (ii)  long	increases	the	bytes	for	a	particular	
data	type,	 thus	increasing	the	range	of	
values. 

90. Nested if statement.	The	statement	sequence	
of	if	or	else	may	contain	another	if	statement	
i.e., the if .. else statements can be nested 
within one another as shown below:

 

 In an nested if.. else statement, Each 
‘else’ matches with the nearest unmatched 
preceding	‘if”.
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91. There	are	four	types	of	scopes	in	C++.	They	
are,

	 i)	 Local	scope
	 ii)	 Function	scope
	 iii)	 File	Scope
	 iv)	 Class	scope	

92. strlen() function is used to return the length 
of	the	string	or-	a	string	array.

 Eg : strlen(“school”). It returns the value 6.  

93.	 A	matrix	is	a	set	of	m	×	n	numbers	arranged	
in	the	form	of	a	rectangular	array	of	m	rows	
and	n	columns.	Matrics	can	be	represented	
through	2-D	arrays.	

94.	 A	 class	 is	 a	 new	 way	 of	 creating	 and	
implementing	a	user	defind	data	type.	Classes	
provide	a	method	for	packing	together	data	
of	different	types.	A	class	is	way	to	bind	the	
data and its associated functions together. 

95. 1.  Data members are the data variables that 
represent	the	features	of	properties	of	a	
class.

 2.  Memeber functions are the functions 
that	 perform	 specific	 tasks	 in	 class.	
Member functions are called as methods 
and data members are also called as 
attributes.

96. The	 term	 operator	 overloading,	 refers	 to	
giving	additional	functionality	to	the	normal	
C++	operators	 like	+,++,-,–,	+=,	 -=,	*.<,>.	
The statement sum = num1 + num2 would be 
interpreted	as	a	statement	meant	to	perform	
addition	 of	 numbers	 (integer/float/double)	
and store the result in the variable sum. 

97. Functions of constructor are: 
 (i)   The constructor function initializes the 

class	object
	 (ii)	 	The	memory	space	is	allocated	to	an	

object.

98. There	 are	 different	 types	 of	 inheritance.	
Single	 inheritance,	multiple	 inheritance,	
multilevel	 inheritance,	 hybrid	 inheritance	
and hierarchical inheritance. 

99. Computers	helps	us	to	look	at	the	government	
websites	 and	 the	 services	 provided	 by	
them.	The	 various	websites	 provided	 by	
the government give the details about the 
departments,	 specific	 functions,	 special	
schemes, documents, contacts, links, IAS 
intranet,	site	map,	search,	what’s	new,	press	
releases, feedback. These websites are both 
in English and Tamil. 

100. A	virus	is	a	self-replicating	program	that	can	
cause	damage	to	data	and	files	stored	on	your	
computer.	These	 are	 programs	written	 by	
programmers	with	great	programming	skills	
who	are	motivated	by	the	need	for	a	challenge	
or to cause destruction. 57000 known virus 
programs	are	in	existence.	Six	new	viruses	
are	found	each	day.	

PART -III

101. The	Find	and	Replace	feature	in	StarOffice	
Writer	to	search	for	and	to	replace	words	in	
a	text	document.	

	 To	Find	and	Replace	Text

 (i)  Choose Edit 	 Find	&	Replace	The	
Find	and	Replace	dialog	box	appears.	

	 (ii)	 	In	the	Search	for	box,	type	the	text	or	
word of a document to be searched. 

	 (iii)	 	In	 the	Replace	with	 	 box,	 enter	 the	
replacement	word	or	phrase.

 (iv) Click  Find  to start the search.
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 (v)	 	To	find	the	first	instance	of	the	word	or	
phrase,	do	one	of	the	following:

	 	 (a)	 	To	replace	the	found	instance	of	
the	 text	 of	 	 a	 document	 entered	
in	 the	Replace	with	 box,	 click	
Replace.

	 	 (b)	 	To	 replace	 all	 instances	 of	 the	
text	of	a	document	entered	in	the	
Replace	with	box,	Click	Replace	
All.

	 	 (c)	 	To	 skip	 the	 found	 text	 and	 to	
continue the search, click Find 
again.

	 6.	 Click	Close	to	finish the search. 

102.The functions of each icon in the toolbar 
are :

 	 –		Table Fixed.

 	 –	 Table Fixed, Proportional.

 	 –	 Table Variable.

 	 –	 Merge cells : This icon is used to 
combine two or more cells into a 
single cell.

 	 –	 Split cells :  This icons is used to 
split	a	cell	into	two	or	more	cells.

 	 – Optimise :  Clicking on this 
icon	 displays	 a	 pop-up	menu	
with	options	like	Space	columns	
equally,	 Space	 rows	 equally,	
Opt imum	 row	 height 	 and	
Optimum	Column	width.

 	 –	 Inserting Row : This icon is used 
to insert a row below the current 
row.

  –	 Inserting Column :  This icon 
inserts a column to the right of 
the current column.

 	 –	 Delete Row :  This icon deletes 
the current row from the table.

 	 –	 Delete Column :  This icon 
deletes the current column from 
the table.

 	 – Borders :	 	This	 icon	 display	 a	
floating toolbar with different 
border	option	for	the	table.

 	 –	 Line Style : This icon is used to 
choose	the	style	of	line	to	be	used	
for the borders.

 	 –	 Border Colour : Clicking on this 
icon	displays	a	palette	of	colours	
that can be used as a border 
colour for the table. 

103. To	get	Insert	Object	floating	toolbar,	click	on	
View	Toolbar	Insert	Object	option.	It	displays	
with following icons :

1. Insert chart icon : 

		 This	icon	is	used	for	presenting	the	data	
in the worksheet in the form of charts 
of	different	kinds	such	as	bar	chart,	pie		
chart,	lines,	X-Y	plot,	etc.		

2. Insert Formula icon :  

  This icon is used for inserting a formula 
in	 the	 worksheet	 for	 performing	
calculations. 

3. Insert Floating Frame icon : 

  This icon is used to generate a scrolling 
screen within a worksheet. 
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4. Insert Movie and Sound icon : 

  This icon is used to insert sound or video 
files	into	the	current	worksheet.	

5. Insert OLE object icon : 

		 This	icon	is	used	to	insert	objects	from	
other	application	into	a	worksheet.	

6. Insert Applet icon : 

		 This	icon	is	used	to	import	Java	Applets	
into the worksheet. 

104. An	electronic	spreadsheet	is	a	worksheet	used	
in	a	computer	to	create	and	quickly	perform	
'What	 if'	 analysis	 of	 interrelated	 columnar	
data	in	workspaces.

The main advantages of using electronic 
spreadsheets	are	:
i)  Calculations are automated through 

the	built-in	mathematical,	financial	and	
statistical functions.

ii)	 	Accurate	results	to	any	desired	level	of	
decimal	points	are	possible.

iii)	 Worksheets	can	be	quite	big	in	size.
iv)	 	Any	part	of	the	worksheet	can	be	viewed	

or edited.
v)  Worksheet can be saved and retrived 

later.
vi)	 	Any	part	of	an	existing	worksheet	can	

be	merged	with	 any	 existing	 or	 new	
worksheet.

vii)	 	Any	part	or	whole	of	the	worksheet	can	
be	printed	in	a	desired	format.

viii)  Worksheet data can be viewed in the 
form	of	graphs	or	charts.	

ix)	 	The	 worksheet	 information	 can	 be	
transferred	 to	 any	 database	 or	word	
processing	software.

105. The classification of Database based on 
conceptual	structures	are:

	 (i)	Flat-File	database,	(ii)	Relational	database,	 
(iii) Hierarchical database, (iv) Network 
database,	(v)	Object-Oriented	database.

 (i)  Flat-File Database. A database file 
that consists of a single data table is a 
Flat-file	database.	Flat-file	database	can	
be	quite	useful	 for	certain	 single-user	
or	 small-group	 situations,	 especially	
for maintaining lists such as address 
lists or inventories. Data that is 
stored,	managed,	 and	manipulated	 in	
spreadsheet	 is	 another	 example	 of	 a	
flat-file	database.	

 (ii)  Relational database. A relational 
structure	represents	a	database	made	up	
of a set of related tables. In a relational 
database,	one	or	more	common	fields	
existing	in	two	or	more	tables	create	a	
relationship	between	these	tables.	The	
common	field	 or	fields	 are	 called	 the	
Keys.	

	 	 	A	primary	key	 is	 a	 key	 that	 uniquely	
identifies	a	record	in	a	database	table.	
In	relational	databases,	a	primary	key	
can	consist	of	one	or	more	fields.	

   The relational database structure is 
the	most	prevalent	database	in	today’s	
business organizations. 

 (iii)  Hierarchical database. The hierarchical 
database	 structures	 were	 primarily	
used	 on	Main	 Frame	 computers.	 In	
hierarchical database, records are 
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organized	in	a	tree	like	structure	by	type.	
The	relationship	between	record	types	
is	said	to	be	a	parent-	child	relationship,	
in	which	any	child	type	relates	only	to	
a	single	parent	type.	

 (iv)  Network database.The Network 
database	 is	 very	 similar	 to	 the	
hierarchical	 structure	 except	 that	 any	
one	record	type	can	relate	to	any	number	
of	other	record	types.

 (v)  Object Oriented database.	An	Object	
Oriented database is a newer structure 
that has been generating a greet deal 
of	 interest	 in	 recent	years.	The	object	
oriented	 structure	 groups	 data	 items	
and their associated characteristics, 
attributes	and	procedures	into	complex	
items	 called	 objects.	 Physically	 an	
object	 can	 be	 anything:	 a	 product	 or	
event,	 such	 as	 house,	 an	 appliance,	
an	art	piece,	a	customer	complaint,	or	
even	a	purchase.	An	object	 is	defined	
by	 its	 characteristics,	 attributes	 and	
procedures.	An	object’s	characteristics	
can	be	text,	sound,	graphics	and	video.	
Examples	 of	 attributes	 might	 be	
colour,	 size,	 style,	quantity	and	price.	
A	procedure	refers	to	the	processing	or	
handling that can be associated to the 
object.	

106.	for	(;	;	)	..	loop:	is	an	entry	controlled	loop	
and	is	used	when	an	action	is	to	be	repeated	
for	 a	 predetermined	number	 of	 times.	The	
syntax	is	

 for(initial value ; test-condition ; increment)

 {

  action block;

 }

	 The	general	working	of	for(;;)loop	is:

(i)	 The	 control	 variable	 is	 initialized	 the	first	
time	when	the	control	enters	the	loop	for	the	
first	time.	

(ii)	 Test	 condition	 is	 evaluated.	The	 body	 of	
the	loop	is	executed	only	if	the	condition	is	
TRUE.	Hence	for(;;)	loop	is	called	as	entry	
controlled	loop.	

(iii)	On	repetition	of	the	loop,	the	control	variable	
is	incremented	before	the	body	of	the	loop	is	
executed.	

(iv)	The	loop	is	terminated	when	the	test	condition	
evaluates to false. 

The	following	program	illustrates	for(;;)	loop:

 #  include <iostream.h>

 #  include <conio.h>

 void main( ) 

 {

  int i,fact = 1;

  for(i = 1; i < 6; i++)

	 	 fact	*=i;

  cout << “\nThe factorial of the number 
 is ..” << fact;

 }
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for (i = 1; i < 6; i++)

Incrementation (1st segment)

Test condition (2nd segment)

Initialisation of control

variable (3rd segment)

(i)	 Initialisation	is	executed	only	once,	i.e.,	when	
the	loop	is	executed	for	the	first	time.	

(ii) Test condition is evaluated before the 
commencement	of	every	iteration.	

(iii)	Incrementation	 is	 evaluated	 and	 executed	
before the commencement of new iteration.

107. Call	statement	to	a	function	makes	a	compiler	
to	 jump	 to	 the	 functions	 and	 also	 to	 jump	
back to the instrument following the call 
statement.	 This	 forces	 the	 compiler	 to	
maintain	overheads	like	STACKS	that	would	
save	certain	special	instruments	pertaining	to	
function call, return and its arguments. This 
reduces	 the	 speed	 of	 program	 execution.	
Hence	 under	 certain	 situations	 specially	
when the functions are small (less number 
of	 instructions),	 the	 compiler	 replaces	 the	
function	call	statement	by	its	definition	i.e.,	
its	 code	 during	 program	 execution.	This	
feature is called as inlining of a function 
technically	called	as	inline	function.	

	 For	example,	

 # include <iostream.h>

 # include <conio.h>

	 inline	float	convert_feet(int	x)

 {

	 	 return	x	*	12;

 }

 void main( )

 {

  clrscr( );

  int inches = 45;

	 	 cout	<<	convert_feet(inches);

  getch( );

 }

108. The	 ability	 of	 the	 function	 to	 process	 the	
message or data in more than one form is 
called function overloading.

 Rules for function overloading are :

 (i)  Each overloaded function must differ 
either	 by	 the	 number	 of	 its	 formal	
parameters	or	their	data	types.		

	 (ii)	 	The	return	type	of	overloaded	functions	
may	or	may	not	be	the	same	data	type.	

 (iii)  The default arguments of overloaded 
functions	are	not	considered	by	the	C++	
compiler	as	part	of	the	parameter	list.	

 (iv)  Do not use the same function name for 
two unrelated functions. 

109.  output

 3
 4
 5

Program :
# include <iostream. h>
# include < conio.h >
class A
{
	 public:
 int a1,a2:a3;
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]]]]

 void getdata[]
 {
   a1=3;
   a2=3;a3=5;
  }
}
Class	B::	public	A
{
 Public:
 void func()
 {
  int b1:b2:b3;
  A::getdata();
  b1=a1;
  b2=a2;
  a3=a3;

	 	 cout<<b1<<'\n'<<b2<<'\n'<<B;
 }
void main()
{
 clrscr();
	 B	der;
 der :func();
 getch()
}

110.   Output :  
 constructor	of	class	sample
	 object
 The two integers are 25 85
 The sum of integers 110
	 Destructor	of	class	sample.




